Fix: FastCGI: incomplete headers (0 bytes) received from server – MAMP Pro

Fix: FastCGI: incomplete headers (0 bytes) received from server – MAMP Pro

If you are experiencing 500 Internal Server errors on your websites in MAMP Pro, review your PHP error log. If you see the following errors around the same time you received the 500 erros on your websites, follow the steps below.

 

[date] [error] [client] FastCGI: comm with server "/Applications/MAMP/fcgi-bin/php7.1.8.fcgi" aborted: idle timeout (30 sec)

[date] [error] [client] FastCGI: incomplete headers (0 bytes) received from server "/Applications/MAMP/fcgi-bin/php7.1.8.fcgi"

[date] [error] [client] [notice] caught SIGTERM, shutting down

[date] [error] [client] [notice] FastCGI: process manager initialized (pid 21215)

[date] [error] [client] [notice] Digest: generating secret for digest authentication ...

[date] [error] [client] [notice] Digest: done

 

  1. In MAMP Pro, select PHP under LANGUAGES.
 
  1. Enable Xdebug (Debugger).
 
Mamp pro xdebug php option
 

For more information visit MAMP Pro documentation here on this.

 







* Please use the comment form below. Comments are moderated.*



Related Posts

 

Comments

Guest
Guest - Tobi on Friday, 05 June 2020 07:20

Doesn't help anyway

Doesn't help anyway
Guest
Guest - Dan on Wednesday, 11 March 2020 08:32

It helped! Why does it work now?

It helped! Why does it work now?
Guest
Guest - typoman on Monday, 28 May 2018 08:54

Hey this helped! Thanks!

Hey this helped! Thanks!
Guest
Sunday, 05 February 2023