Become The Solution Chicago Logo


Mac 10.11 System Requirements

Mac 10.11 System Requirements
The latest version of Mac X 10.11 El Captain – per Apple's Website system requirements are as follows.
 
 
Hardware:
 




MacBook (Early 2015)
MacBook (Late 2008 Aluminum, or Early 2009 or newer)
MacBook Pro (Mid/Late 2007 or newer)
MacBook Air (Late 2008 or newer)
Mac mini (Early 2009 or newer)
iMac (Mid 2007 or newer)
Mac Pro (Early 2008 or newer)
Xserve (Early 2009)

 

System Requirements:
 
OS X v10.6.8 or later
2GB of memory
8.8GB of available storage
* Please use the comment form below to let us know if you experience issues, have questions, or can provide solution. We want and encourage feedback. *



Rate this blog entry:
1

Related Posts

 

Comments

No comments made yet. Be the first to submit a comment
Guest
Sunday, 22 October 2017
Follow Us Online!
Become The Solution Facebook PageBecome The Solution Twitter Solution ChicagoBecome The Solution Google PlusBecome The Solution InstagramBecome The Solution LinkedInBecome The Solution YouTube

Subscribe to Become The Solution!